Cisco Switch Configuration



Configuring VLANs on a Cisco Catalyst Switch

Step 1: Connect the console cable to the switch

Step 2: Use HyperTerminal (or equivalent) to connect to switch and at the > prompt, type Enable then press enter

Step 3: Type Conf t then press enter

Step 4: Type Int vlan 1 then press enter

Step 5: Type Ip address 123.1.1.1 255.0.0.0 then press enter

Step 6: Type No shutdown then press enter

The switch now has an IP address and you can use a browser to finish configuration

Step 7: Use IE to connect to the IP address just set

Step 8: In the Authentication window, leave name blank, enter correct password and click on ok.

Step 9: In the browser, choose Cluster Management Suite or Visual Switch Manager

Step 10: When the following dialog box appears, type in the password again and click on OK




Note: After clicking on OK, you will have quite a wait for the system to load the next screen, but it will load!



Step 11: All switches have at least one VLAN, VLAN 1… To create another for your Voice devices, select VLAN / VTP Management



Step 12: Choose the LAN Configuration tab then Click on New

Step 13: Add a VLAN ID in the new dialog box along with a VLAN name and click on OK, then ok once more.

Step 14: To set up VLAN membership for ports, choose VLAN / VLAN Membership



Step 15: Select the Port from the list that appears

Step 16: On the final window, choose Static Access and type in the VLAN number and click on ok, then ok once again. The device connected to the port is now set to work with VLAN 1

Step 17: For Trunk Ports, (i.e. IP Phones and Switch to Switch Ports), they need to be set up so that the port accepts data destined for more than one VLAN, so,

Step 18: Select VLAN / VLAN Membership

Step 19: Choose the port to be configured

Step 20: Select 802.1Q as the Trunk mode, click on ok then ok one more time










Example of VLAN Configuration File on Cisco Catalyst switch

If web access is not possible then Catalyst switch can be configured via the command line. To configure an interface you enter interface configuration mode.

Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname swt_group1
!
ip subnet-zero
!
! Router Port
interface FastEthernet0/1
switchport trunk encapsulation dot1q (sets the encapsulation type to 802.1Q)
switchport trunk allowed vlan 1,2,1002-1005 (Sets the VLANs allowed in the trunk)
switchport mode trunk (Sets the port to a VLAN trunk)
spanning-tree portfast (Sets portfast on the port)
!
!3300 icp port
interface FastEthernet0/2
switchport access vlan 2
spanning-tree portfast
!
!Phone Port
interface FastEthernet0/3
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
!Data only Port
interface FastEthernet0/4
!
interface VLAN1
ip address 192.168.9.2 255.255.255.0
no ip directed-broadcast
no ip route-cache
!
interface VLAN4
description Voice_VLAN
no ip directed-broadcast
no ip route-cache
shutdown
!









To verify your set up use the show vlan brief command. Note: trunk ports are not shown.

Results of Show vlan :

swt_group1#show vlan bri
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/4, Fa0/5, Fa0/6, Fa0/7,
Fa0/8, Fa0/9, Fa0/10, Fa0/11,
Fa0/12, Fa0/13, Fa0/14, Fa0/15,
Fa0/16, Fa0/17, Fa0/18, Fa0/19,
Fa0/20, Fa0/21, Fa0/22, Fa0/23,
Fa0/24
2 VoiceVLAN active Fa0/2
1002 fddi-default active
1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active

Comments

Popular Posts